Chapter 7 : Lab 7.3.3 Configuring and Testing the Rapid Spanning Tree Prototype

Task 1: Configure all devices

Step 1: Configure S1 and S2

Configure the host name, access, and command mode passwords on each switch.

Step 2: Configure interface VLAN 1

Configure the VLAN1 IP address and default gateway on each switch.

Step 3: Configure FC-ASW-1 for server and end user VLANs

VLAN Number VLAN Name
10 Servers
20 Users

Step 4: Configure ProductionSW for server and end user VLANs

VLAN Number VLAN Name
10 Servers
20 Users

Step 5: Assign ports to VLANs on FC-ASW-1

FC-ASW-1#configure terminal

FC-ASW-1(config)#interface Fa0/5

FC-ASW-1(config-if)#switchport mode access

FC-ASW-1(config-if)#switchport access VLAN10

FC-ASW-1(config-if)#interface Fa0/6

FC-ASW-1(config-if)#switchport mode access

FC-ASW-1(config-if)#switchport access VLAN20

Step 6: Assign ports to VLANs on ProductionSW

ProductionSW#configure terminal

ProductionSW(config)#interface Fa0/5

ProductionSW(config-if)#switchport mode access

ProductionSW(config-if)#switchport access VLAN10

ProductionSW(config-if)#interface Fa0/6

ProductionSW(config-if)#switchport mode access

ProductionSW(config-if)#switchport access VLAN20

Step 7: Configure trunk ports on FC-ASW-1 to the router and ProductionSW

FC-ASW-1(config)#interface Fa0/1

FC-ASW-1(config-if)#switchport mode trunk

FC-ASW-1(config-if)#interface Fa0/2

FC-ASW-1(config-if)#switchport mode trunk

FC-ASW-1(config-if)#interface Fa0/4

FC-ASW-1(config-if)#switchport mode trunk

Step 8: Configure trunk ports on ProductionSW to FC-ASW-1

ProductionSW(config)#interface Fa0/2

ProductionSW(config-if)#switchport mode trunk

ProductionSW(config-if)#interface Fa0/4

ProductionSW(config-if)#switchport mode trunk

Step 9: Configure VTP on both switches

FC-ASW-1#vlan database

FC-ASW-1(vlan)#vtp server

Step 10: Configure ProductionSW to be a VTP client

ProductionSW#vlan database

ProductionSW(vlan)#vtp client

ProductionSW(vlan)#vtp domain ServerFarm

Step 11: Configure Rapid Spanning Tree Protocol

On each switch, configure Per-VLAN Rapid Spanning Tree Protocol.

FC-ASW-1(config)#spanning-tree mode rapid-pvst

ProductionSW(config)#spanning-tree mode rapid-pvst

Step 12: Perform basic router configuration

Configure hostname, passwords, and line access on R1.

Step 13: Configure Subinterface Fa0/0

BR4#configure terminal

BR4(config)#interface Fa0/0

BR4(config-if)#no shut

BR4(config-if)#interface Fa0/0.1

BR4(config-subif)#description VLAN1

BR4(config-subif)#encapsulation dot1q 1

BR4(config-subif)#ip address 10.0.0.1 255.255.255.0

BR4(config-subif)#interface Fa0/0.10

BR4(config-subif)#description VLAN10

BR4(config-subif)#encapsulation dot1q 10.

BR4(config-subif)#ip address 10.10.10.254 255.255.255.0

BR4(config-subif)#interface Fa0/0.20

BR4(config-subif)#description VLAN20

BR4(config-subif)#encapsulation dot1q20

BR4(config-subif)#ip address 10.10.20.254 255.255.255.0

BR4(config-subif)#end

BR4#

Step 14: Configure two hosts for server VLAN, and two hosts for end user VLAN

a. H1 and H3 should be given IP addresses in the Servers VLAN, with a default gateway of

10.10.10.254.

b. H2 and H4 should be given IP addresses in the Users VLAN, with a default gateway of 10.10.20.254.

Task 2: Perform basic connectivity tests

Step 1: Test intra-VLAN connectivity

a. Ping from H1 to H3.

Is the ping successful?

Ya

If the ping fails, troubleshoot the configuration on the hosts and the VLAN configuration on the switches.

b. Ping from H2 to H4.

Is the ping successful?

Ya

If the ping fails, troubleshoot the configuration on the hosts and the VLAN configuration on the switches.

Step 2: Test inter-VLAN connectivity

Ping from a host on the Servers VLAN to a host on the Users VLAN.

Is the ping successful?

Ya

If the ping fails, troubleshoot the router and switch configurations.

Task 3: Introduce link and device failures into the network, and observe results

Step 1: Determine the port status of the spanning tree on the server switch

FC-ASW-1#show span

VLAN0010

Spanning tree enabled protocol ieee

Root ID Priority 32778

Address 0030.F2C9.90A0

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32778 (priority 32768 sys-id-ext 10)

Address 0090.21AC.0C10

Aging Time 300

Interface Role Sts Cost Prio.Nbr Type

—————- —- — ——— ——– ————————–

Fa0/1 Desg FWD 19 128.3 Shr

Fa0/2 Root FWD 19 128.3 Shr

Fa0/4 Altn BLK 19 128.3 Shr

Fa0/5 Desg FWD 19 128.3 Shr

VLAN0020

Spanning tree enabled protocol ieee

Root ID Priority 32788

Address 0030.F2C9.90A0

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32788 (priority 32768 sys-id-ext 20)

Address 0090.21AC.0C10

Aging Time 300

Interface Role Sts Cost Prio.Nbr Type

—————- —- — ——— ——– ————————–

Fa0/1 Desg FWD 19 128.3 Shr

Fa0/2 Root FWD 19 128.3 Shr

Fa0/4 Altn BLK 19 128.3 Shr

Fa0/6 Desg FWD 19 128.3 Shr

Which port is not currently participating in forwarding data?

Fa0/4 adalah alternatif

Step 2: Induce a link failure on the server switch

Remove the cable from one of the forwarding ports on FC-ASW-1.

Step 3: View the adjustment to the spanning-tree

Re-issue the show span command.

How long did it take the switches to determine and utilize a backup link?

Step 4: Induce a device failure on the network

Turn off the ProductionSW switch.

Ping from H1 to H2.

Was the ping successful?

Yes, both hosts are on the FC-ASW-1 switch and inter-VLAN

routing is still taking place.

Step 5: Reflect on the test results

In a network with multiple branch offices, why is the use of Rapid Spanning Tree Protocol important?

RSTP adalah penting untuk memastikan konektivitas perangkat pada layer akses di setiap kantor cabang dan bahwa sumber daya seperti server yang dapat diakses oleh pengguna di kantor-kantor lain yang bergantung pada mereka, dalam hal terjadi kegagalan switch-terkait setempat.

Why is it important when implementing a server farm?

RSTP akan membantu untuk memastikan bahwa switch dapat sembuh dengan cepat dan menyimpan server diakses oleh pengguna dalam hal link, switch atau kegagalan port.



Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s