Chapter 6 : Routing

Lab 6.1.2 Creating a Network Diagram from Routing Tables

Step 1: Examine the routing table entries for the router R1

a. Examine the show ip route output from router R1 shown below.
R1#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route
Gateway of last resort is not set
C 172.17.0.0/16 is directly connected, Serial0/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
C 192.168.2.0/24 is directly connected, FastEthernet0/1
R 192.168.3.0/24 [120/1] via 172.17.0.2, 00:00:17, Serial0/0
R 192.168.4.0/24 [120/1] via 172.17.0.2, 00:00:17, Serial0/0

b. How many networks does router R1 know about?     (5)

c. How many networks are directly connected to this router?     (3)

d. How many networks have been learned from another router?     (2)

e. Using the codes at the beginning of the show ip route output, what does the “R” mean?     (R = router)

f. In the routes learned via RIP, to which device does the IP address 172.17.0.2 belong?     (ada)

g. In the routes learned via RIP, to which device is Serial0/0 referring and what does it mean?

(0/0 adalah interfacenya yaitu menampilkan informasi khusus hardware interface. Perintah ini harus di-set termasuk nomor port/slot dari interface serial)

Step 2: Examine the routing table entries for router R2

a. Examine the show ip route output from router R2 shown below..
R2#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route
Gateway of last resort is not set
C 172.17.0.0/16 is directly connected, Serial0/0
R 192.168.1.0/24 [120/1] via 172.17.0.1, 00:00:17, Serial0/0
R 192.168.2.0/24 [120/1] via 172.17.0.1, 00:00:17, Serial0/0
C 192.168.3.0/24 is directly connected, FastEthernet0/0
C 192.168.4.0/24 is directly connected, FastEthernet0/1

b. How many networks does router R2 know about?     (5)

c. How many networks are directly connected to this router?     (3)

d. How many networks have been learned from another router?     (2)

e. In the routes learned via RIP, to which device does the IP address 172.17.0.1 belong?     (ada)

f. In the routes learned via RIP, to which device is Serial0/0 referring and what does it mean?

(Serial 0/0 adalah interface –nya yaitu menampilkan informasi khusus hardware interface. Perintah ini harus di-set termasuk nomor port/slot dari interface serial)

Step 3: Document router interfaces and IP addresses

a. Based on the show ip route output from routers R1 and R2, fill in the table with the router name, the names of all interfaces in use, and their IP addresses and subnet masks. Use the first available IP address for each of the local network FastEthernet interfaces.

b. In this example, can the exact IP address of all router interfaces be determined by looking at the routing tables?

(bisa)

c. Which router interface IP addresses can be determined from the routing tables?

Step 4: Create a network topology diagram

Based on the show ip route output from routers R1 and R2, and the information you entered in the table, draw the network topology here. Be sure to include all devices, connections, interfaces, IP addresses, subnet masks, and network numbers

Step 5: Reflection
a. What do you think would happen to the entries in the routing table on R1 if one of the Ethernet networks on R2 was disconnected?    (sinyal akan terputus)

b. What do you think would happen to the entries in the routing tables on R1 and R2 if the Serial interface on R2 was shut down?

Lab 6.1.5 Configure and Verify RIP

Step 1: Build the network and configure the routers

a. Build a network as shown in the topology diagram

b. In global configuration mode, configure the hostnames as shown in the chart in the topology diagram.
Next, configure the interfaces according to the chart. You can use either the command-line interface
(CLI) or Security Device Manager (SDM) GUI interface, if available.
NOTE: Refer to Lab 5.3.5 if you have difficulty with the basic router configuration. That lab provides
instructions for using the Cisco IOS command line interface.

Step 2: Check the routing table entries

a. View the IP routing table for R1 using the show ip route command:
R1>show ip route
<output omitted>
Gateway of last resort is not set
C 172.16.0.0/16 is directly connected, FastEthernet0/0
C 172.17.0.0/16 is directly connected, Serial0/0/0

b. What is the significance of the “C” to the left of the 172.16.0.0 and 172.17.0.0 network entries in the routing table?

(IP 172.16.0.0 menggunakan interface type DCE sedangkan pada IP 172.17.0.0 menggunakan interface type DTE)

Step 3: Configure the routing protocol of the routers

There are two versions of RIP: version 1 and version 2. It is important to specify RIP version 2 (RIPv2) in this
configuration, because RIPv2 is the most current version. Some routers default to RIPv2, but it is best to not
assume that is the case.

a. In global configuration mode, enter the following on R1:
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 172.16.0.0
R1(config-router)#network 172.17.0.0
R1(config-router)#exit
R1(config)#exit
b. Save the R1 router configuration:
R1#copy running-config startup-config

c. In global configuration mode, enter the following on R2:
R2(config)#router rip version 2
R2(config-router)#version 2
R2(config-router)#network 172.17.0.0
R2(config-router)#network 172.18.0.0
R2(config-router)#exit
R2(config)#exit

d. Save the R2 router configuration:
R2#copy running-config startup-config

Step 4: Configure the hosts with the proper IP address, subnet mask, and default gateway

a. Configure the host attached to R1 with an IP address, subnet mask and default gateway that is
compatible with the IP address of the Fast Ethernet interface (172.16.0.0).

b. Configure the host attached to R2 with an IP address, subnet mask and default gateway that is compatible with the IP address of the Fast Ethernet interface (172.18.0.0).

c. Verify that the internetwork is functioning by pinging the Fast Ethernet interface of the other router.

d. From the host attached to R1, is it possible to ping the R2 router Fast Ethernet interface?

(mungkin  karena sudah menggunakan gateway yang akan menghubungkan dua buah jaringan yang berbeda)

e. From the host attached to R2, is it possible to ping the R1 router Fast Ethernet interface?

(mungkin  karena sudah menggunakan gateway yang akan menghubungkan dua buah jaringan yang berbeda)

f. If the answer is no for either question, troubleshoot the router configurations to find the error. Then do the pings again until the answer to both questions is yes. Be sure to check physical cabling for problems and bad connections and make sure that you are using the correct cable types.

Step 5: Show the routing tables for each router

a. In enable or privileged EXEC mode, examine the routing table entries using the show ip route command on router R1.
R1#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B –
BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS
inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route
Gateway of last resort is not set
C 172.17.0.0/16 is directly connected, Serial0/0
C 172.16.0.0/16 is directly connected, FastEthernet0/0
R 172.18.0.0/16 [120/1] via 172.17.0.2, 00:00:17, Serial0/0

b. What are the entries in the R1 routing table?     (R1 terkoneksi pada jaringan 172.17.0.0/16 dan 172.16.0.0/16)

c. What is the significance of the “R” to the left of the 172.18.0.0 network entry in the routing table?

(172.18.0.0 terhubung ke jaringan melalui 172.17.0.2)

d. What does “via 172.17.0.2” mean for this network route? (Router mempelajari melalui RIP dengan device 172.17.0.2)

e. What does “Serial0/0” mean for this network route?    (Serial interfacenya atau port/slot)

f. Examine the routing table entries using the show ip route command on router R1.
R2#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGPD – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter
area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route
Gateway of last resort is not set
C 172.17.0.0/16 is directly connected, Serial0/0
R 172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:13, Serial0/0
C 172.18.0.0/16 is directly connected, FastEthernet0/0

g. What are the entries in the R2 routing table?     (172.16.0.0/16)

Step 6: Use debug to observe RIP communications

Using the debug ip rip command, you can see real-time communication and updates passing between
routers that are running RIP.
NOTE: Running debug commands puts a significant load on the CPU of the router. Do not use debug
commands on a production network, if possible.

a. On router R1, enter the debug ip rip command from privileged EXEC mode. Examine the exchange of routes between the two routers. The output should look similar to that shown here.
R1#debug ip rip
RIP protocol debugging is on
R1#
00:51:28: RIP: sending v2 update to 224.0.0.9 via Serial0/0 (172.17.0.1)
00:51:28: RIP: build update entries
00:51:28: 172.16.0.0/16 via 0.0.0.0, metric 1, tag 0
00:51:49: RIP: received v2 update from 172.17.0.2 on Serial0/0
00:51:49: 172.18.0.0/16 via 0.0.0.0 in 1 hops
00:51:57: RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0
(172.16.0.1)
00:51:57: RIP: build update entries
00:51:57: 172.17.0.0/16 via 0.0.0.0, metric 1, tag 0
00:51:57: 172.18.0.0/16 via 0.0.0.0, metric 2, tag 0
b. Enter the command undebug all to stop all debugging activity.
R1#undebug all
All possible debugging has been turned off
R1#

c. What interface does router R1 send and receive updates through?    (R1 mengirim ke alamat 224.0.0.9 dan R1 menerima dari 172.17.0.2)

d. Why does the route to 172.17.0.0 have metric of 1 and the route to 172.18.0.0 have a metric of 2?

(Karena pada ruter ke 172.17.0.0 memiliki satu lompatan atau terkoneksi langsung sehingga disebut 1 metric sedangkan 172.18.0.0 memiliki dua lompatan karena tidak terkoneksi secara langsung melainkan melalui router lain)

e. Log off by typing exit and turn off the router.

Step 7: Reflection

a. What do you think would happen to the routing table on router R1 if the Ethernet network on router R2 went down?

(Koneksi antara R1 dan R2 akan terputus)

b. What do you think would happen if router R1 was configured to run RIPv1, and R2 was configured to run RIPv2?

(Router dapat berkomunikasi dengan router lain sehingga dapat menetukan jalan yng terbaik dalam pengiriman paket data  tanpa memperhatikan subnet, konfigurasi ini di butuh kan untuk proses routing untuk menentukan interface mana yang akan mengirim data atau menerima)

Lab 6.2.5 Configuring BGP with Default Routing

Step 1: Configure basic information on each router

a. Build and configure the network according to the topology diagram, but do not configure a routing protocol. If necessary, refer to Lab 5.3.5, “Configuring Basic Router Settings with IOS CLI,” for instructions on setting hostname, passwords, and interface addresses.

b. Configure the host PC IP address and subnet mask on the customer network to be compatible with the CR router FastEthernet interface with a default gateway of 192.168.1.1.

c. Use ping to test connectivity between the directly connected routers. Was the CR router able to reach the ISP2 router? ____ Was the customer host able to reach ISP1? ____

d. Configure a loopback interface with an IP address for the ISP1 and ISP2 routers, as shown in the topology diagram. A loopback interface is a virtual interface that simulates a real network for testing purposes. Configure Loopback Interface on ISP1 router.
ISP1>enable
ISP1#configure terminal
ISP1(config)#interface loopback0
ISP1(config-if)#ip address 192.168.100.1 255.255.255.0

e. Configure Loopback Interface on ISP2 router.
ISP2>enable
ISP2#configure terminal
ISP2(config)#interface loopback0
ISP2(config-if)#ip address 192.168.200.1 255.255.255.0

Step 2: Configure the default and static routes

a. On the CR router, configure the default route so that users will have access to ISP1:
CR(config)#ip route 0.0.0.0 0.0.0.0 10.10.10.2

b. On the ISP1 router, configure a static route back to the customer’s network:
ISP1(config)#ip route 192.168.1.0 255.255.255.0 10.10.10.1
c. Test connectivity by issuing a ping from the host to ISP1 at 10.10.10.2.
NOTE: If pings are not successful, troubleshoot router and PC configurations and connections as
necessary.

Step 3: Configure BGP on both ISP routers

a. Configure BGP on the ISP1 router:
ISP1(config)#router bgp 100
ISP1(config-router)#neighbor 172.16.1.2 remote-as 200
ISP1(config-router)#network 192.168.1.0
ISP1(config-router)#network 192.168.100.0
ISP1(config-router)#end
ISP1#copy running-config startup-config

major configuration steps.

b. Configure BGP on the ISP2 router:
ISP2(config)#router bgp 200
ISP2(config-router)#neighbor 172.16.1.1 remote-as 100
ISP2(config-router)#network 192.168.200.0
ISP2(config-router)#end
ISP2#copy running-config startup-config

Step 4: View the Routing Tables
The BGP configuration is complete. Check the routing table for each router.
NOTE: Output may vary slightly depending on the model of router used.

a. ISP2#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter
area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 1 subnets
C 172.16.1.0 is directly connected, Serial0/0
C 192.168.200.0/24 is directly connected, Loopback0
B 192.168.1.0/24 [20/0] via 172.16.1.1, 00:40:38
B 192.168.100.0/24 [20/0] via 172.16.1.1, 00:40:38

1) Is network 192.168.1.0 in the routing table of ISP2?     (ya, ada)

2) What letter is at the left of the entry for 192.168.1.0?     (B)

3) What does the letter mean?

4) Is network 192.168.100.0 in the routing table?     (ya, ada)

5) Which router advertised network 192.168.1.0?      (172.16.1.1)

b. ISP1#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 1 subnets
C 172.16.1.0 is directly connected, Serial0/1
B 192.168.200.0/24 [20/0] via 172.16.1.2, 00:33:45
10.0.0.0/24 is subnetted, 1 subnets
C 10.10.10.0 is directly connected, Serial0/0
S 192.168.1.0/24 [1/0] via 10.10.10.1
C 192.168.100.0/24 is directly connected, Loopback0

1) What network(s) did ISP1 learn from ISP2?     (172.16.1.2)

2) How did ISP1 learn about network 192.168.1.0?     (melalui 10.10.10.1)

3) Will ISP1 advertise any networks to the customer router?      (ya)

c. CR#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter
area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route
Gateway of last resort is 10.10.10.2 to network 0.0.0.0
10.0.0.0/24 is subnetted, 1 subnets
C 10.10.10.0 is directly connected, Serial0/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 [1/0] via 10.10.10.2

1) Why are networks 192.168.100.0 and 192.168.200.0 not in CRs routing table?

(Karena semua lalu lintas dari jaringan 192.168.100.0 dan 192.168.200.0 akan menggunakan ISP1 sehingga kedua jaingan ini tidak terdapat di routing table ISP2)

Step 5: Verify connectivity

a. Ping from the host PC on the CR Ethernet network to the Loopback Interface on ISP2.

b. Ping from the ISP2 router to the host PC on the Ethernet network of CR.
NOTE: If pings are not successful, troubleshoot router and PC configurations and connections as
necessary.

Step 6: View BGP information on the ISP routers

a. On the ISP1 router, view the BGP routing.
ISP1#show ip bgp
BGP table version is 4, local router ID is 192.168.100.1
Status codes: s suppressed, d damped, h history, * valid, > best, i –
internal
Origin codes: i – IGP, e – EGP, ? – incomplete
Network Next Hop Metric LocPrf Weight Path
*> 192.168.1.0 10.10.10.1 0 32768 i
*> 192.168.100.0 0.0.0.0 0 32768 i
*> 192.168.200.0 172.16.1.2 0 0 200 i

b. On the ISP2 router, view the BGP routing.
ISP2#show ip bgp
BGP table version is 4, local router ID is 192.168.200.1
Status codes: s suppressed, d damped, h history, * valid, > best, i –
internal
Origin codes: i – IGP, e – EGP, ? – incomplete
Network Next Hop Metric LocPrf Weight Path
*> 192.168.1.0 172.16.1.1 0 0 100 i
*> 192.168.100.0 172.16.1.1 0 0 100 i
*> 192.168.200.0 0.0.0.0 0 32768 i

Step 7: Reflection

Why doesn’t ISP1 advertise any networks to the customer router?

(Karena setiap jaringan sudah di atur menggunakan ISP yang mana, jadi tidak semua jaringan ynag ada di ISP1 di izinkan untuk menggunakan pelayanan router)



Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s